Updates to StatusCast's privacy policy
Informational
March 20, 2:01pm EDT
Updates to StatusCast's privacy policy
Status: closed
Date:
March 20, 2:00pm EDT
Affected Components:
Status pages
Admin application
Notification services
Cloud Providers
Twilio
Mailgun
SendGrid
Azure
Update
March 20, 2:00pm EDT
March 20, 2:00pm EDT
StatusCast is deeply committed to the protection and responsible use of data; we’ve made a few updates to our privacy policy to help you better understand how we collect and use information. We hope these changes more clearly articulate our responsibility to you.
By continuing to use our services on or after March 25, 2020, you indicate your agreement with each of the updated and new terms and policies that are effective as of that date. If you have any questions or concerns, please email support@statuscast.com or reply to this email.