Intermittent connection issues

Incident
February 28, 12:20pm EST

Intermittent connection issues

Status: closed
Start: February 21, 10:31am EST
End: February 28, 12:20pm EST
Duration: 7 days 1 hour 48 minutes
Affected Components:
Cloud Providers Mailgun
Investigating

February 21, 10:31am EST

February 21, 10:31am EST

We've been seeing intermittent connection issues to our API and SMTP endpoints located in the US.

Investigating

February 21, 12:50pm EST

February 21, 12:50pm EST

We are continuing to investigate this issue.

Identified

February 21, 1:33pm EST

February 21, 1:33pm EST

The issue has been identified and a fix is being implemented.

Identified

February 21, 2:25pm EST

February 21, 2:25pm EST

Implemented DDoS protection and monitoring results.

Monitoring

February 21, 4:08pm EST

February 21, 4:08pm EST

DDoS protection is still in place. We are continuing to monitor the system.

Monitoring

February 21, 4:40pm EST

February 21, 4:40pm EST

We are still seeing reports of some customers having issues. Moving the component status to "Degraded Performance".

Monitoring

February 21, 9:58pm EST

February 21, 9:58pm EST

DDoS protection remains in place. We are actively monitoring the system.

Monitoring

February 22, 2:04pm EST

February 22, 2:04pm EST

We continue to investigate solutions and are actively monitoring the system.

Monitoring

February 22, 4:20pm EST

February 22, 4:20pm EST

We are seeing the attack to be shifted to the EU region. We continue to monitor the situation.

Monitoring

February 22, 9:32pm EST

February 22, 9:32pm EST

Our platform is still under an active DDoS attack. We are continuing to apply mitigation tactics and closely monitoring platform performance.

Monitoring

February 23, 9:23am EST

February 23, 9:23am EST

We are continuing to actively mitigate the attack at this time and are closely monitoring the performance of the system.

Monitoring

February 23, 5:52pm EST

February 23, 5:52pm EST

We continue to deploy infrastructure updates, both proactive and reactive, while closely monitoring platform performance.

Monitoring

February 23, 9:16pm EST

February 23, 9:16pm EST

We continue to monitor platform performance.

Monitoring

February 24, 10:26am EST

February 24, 10:26am EST

We continue to execute against our mitigation strategy and closely monitor platform performance.

Monitoring

February 24, 3:40pm EST

February 24, 3:40pm EST

Still executing against the mitigation strategy and monitoring platform performance.

Monitoring

February 24, 9:38pm EST

February 24, 9:38pm EST

We have completed a series of successful infrastructure changes and will monitor traffic closely over the weekend. Unless there is another major development, our next update will be on Monday.

Monitoring

February 27, 1:07pm EST

February 27, 1:07pm EST

We continue to closely monitor traffic and are prepared to make additional proactive and reactive infrastructure changes as required.

Resolved

February 28, 12:20pm EST

February 28, 12:20pm EST

This incident has been resolved.